Social Icons

System Requirements

System RequirementsTo use App Inventor, your computer must meet the following system requirements:Computer and operating system

  • Macintosh (with Intel processor): Mac OS X 10.5, 10.6+
  • Windows: Windows XP, Windows Vista, Windows 7+
  • GNU/Linux: Ubuntu 8+, Debian 5+ (Note: GNU/Linux live development is only supported for WiFi connections between computer and Android device.)


  • Mozilla Firefox 3.6 or higher (Note: If you are using Firefox with the NoScript extension, you'll need to turn the extension off. See the note on the troubleshooting page.)
  • Apple Safari 5.0 or higher
  • Google Chrome 4.0 or higher
  • App Inventor does not support Microsoft Internet Explorer. Windows users should use Chrome or Firefox

Phone or Tablet (or use the on-screen emulator)

  • Android Operating System 2.3 ("Gingerbread") or higher

Whichever model you have, your phone must have an SD card (physical or virtual) installed, or else the phone won't work with App Inventor. Most modern Android phones have virtual SD cards, so this is an issue only for older phones.App Inventor also works with many other Android phones, including models from HTC, Samsung, and Dell, but in many cases you will need to download and install additional software from the manufacturer. You can find details for a few of these models in that table at the bottom of the page for setting up your phone. Even if your phone is not listed there, it is still likely to work with App Inventor. Consult the App Inventor User Forum under "Getting set up and connecting your phone" for advice from others who may be using the same phone.